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 Introduction 
 

Microsoft Visual SourceSafe (VSS) is a source code version control tool used by software 
developers using languages like C/C++, Visual Basic, etc.  I’ve also used VSS for all of my 
SAS programs (.sas) and SAS Enterprise Guide projects (.egp) because it allows SAS 
programmers to create versions of his/her code so that it’s possible to go back a few versions 
to recover old or original code.  This document outlines how to use Visual SourceSafe from 
your desktop computer. 
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What is Microsoft Visual SourceSafe? 
 

 
Microsoft Visual SourceSafe (VSS) stores, versions, and protects files such as computer 
programs.  It is mainly used by software developers to serve as a repository for computer 
programs requiring version control.  VSS automatically increments its internal version number of 
your file each time you make a change and save it to the repository.   
 
You are not limited to storing only textual computer programs.  You can add Word documents, 
Adobe PDF files, executables and DLLs, etc.  Any files that make up your project and which 
may require restoring previous versions can be added to VSS. 
 
Each time you save a file to the repository you are checking in the file.  Each time you retrieve a 
file, you are checking out the file.  The act of checking in the file tells VSS to increment its 

internal version number of your file.  If you need to retrieve an older version of your file, VSS 
allows you to pull the file by date or user 
 
 

Logging into the Repository 
 

In order to use VSS, you need to log into the repository.  Double-click the VSS icon: 
 

 
 

You will be prompted with the VSS login dialog box: 
 

 
 

If you do not have access to the Visual SourceSafe program, please contact your Help Desk.  
You will also need to know the name of the Visual SourceSafe database you can use.  Usually, 
someone in the organization is deemed the SourceSafe Administrator, so try to find out who that 
is. 
 
Enter your username and password and the appropriate database.  Note that you may be 
required to search for a file called srcsafe.ini.  Your SourceSafe Administrator should be able to 
tell you where that is located.  Click OK.  You will be shown a screen similar to the screen image 
below: 
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Initial Visual SourceSafe Setup 
 

The first time you start VSS, a few quick steps are needed to initialize the software for your 
machine.   
 
Step 1 
 
In Windows Explorer, create a new folder labeled VSS in C:\TEMP, for example.  This folder will 
be known as your working folder.  Every time you check out a file from the repository, it will be 

stored in a folder in the working directory.  Note that you can use any folder on your hard-drive 
and a network drive would be a better choice since these are probably backed-up by your 
Network Administrators. The situation still exists where a file that has been checked-out for 
several days and heavily modified, might be lost if the working directory were your local C: drive 
and this was damaged or corrupted. Nevertheless, the previously checked-in version would still 
be recoverable from VSS.  
 
Step 2 
 
You can tell VSS about the new working folder by clicking on the File menu item and choosing 
Set Working Folder.  Enter in your working folder C:\TEMP\VSS, ensure that the check box 
Save as default for project is checked, then click OK. 
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Step 3 
 
Next, click on the Tools menu and choose the Options menu item.  You will see a dialog box 
similar to the one pictured below.   Do the following on the General tab: 
 

 
 
 

 Ensure Act on projects recursively is checked.   

 Ensure that Always keep files checked out is NOT checked.   

 If you’d like, specify your favorite editor to view files within VSS by changing the input 
box for Editor for viewing files.  Note that this is ONLY used when you view a file from 

within VSS.  If you check out a file to your hard drive, you can use any editor you want. 
However, if you frequently view Docs and spreadsheets from within VSS, you may want 
to leave the Editor blank and allow VSS to select an appropriate registered application to 
startup the viewer for that file extension. 

 Enter in the location on your hard-drive where VSS can store temporary files.  This is 
used for viewing a file from within VSS.  The file will be deleted once you are done 
viewing it.  Make sure that this directory exists!  I usually create a directory called 
Temporary Files under C:\TEMP\VSS. 
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Step 4 
 
Next, on the Local Files tab, ensure that your options are the same as the options below. 
 

 
 
Step 5 
 
Next, on the View tab, ensure that your options are the same as the options below.  Specifically, 
ensure that Make selected project the current project is checked, and uncheck Automatically 
refresh file list.   

 

 
 

Step 6 
 
Next, on the Warnings tab, ensure that your options are the same as the options below.  Click 
on OK when you are done. 
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Using Visual SourceSafe 
 

If you take a look at the image of VSS on page 3, you will see that VSS is broken up into two 
panes, a left- and right-hand pane.  The left-hand pane contains the list of folders – called 
projects – and the right-hand pane contains either folders or files related to that particular 
project.  You can have as many projects and subfolders within a project as you want.   
 
There are relatively few steps you need to know in order to use VSS.  They are outlined below: 
 
Creating a New Project 

 
To create a new project to appear in the left-hand pane, ensure that the root folder – labeled as 
“$/” – is selected by clicking on it once.  Then, click the File menu item and select Create 
Project.  A dialog box appears similar to the one below.  Fill in the Project input box by typing in 
the project name followed by a left parenthesis, the job number and a right parenthesis.  You 
can enter in an optional comment.  Click OK when you are done.  You will notice that your new 
project appears in the left-hand pane.  If you would like to add folders under this project, select 
your project by clicking on it once and going through the same procedure as outlined in this 
section.  You can think of a folder as a project below a project. 
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Adding Files to Your Project 
 
In order to add files to your project, ensure that your project is selected by clicking on it once.  
Also, make sure that you have created any extra folders (projects, see above) needed to store 
this file.  Click the File menu item, and choose Add Files.  An example dialog box appears 
below.  Navigate to the directory where your files are, select one or more files to add, then click 
the Add button.  A dialog box pops up allowing you to enter in a description of the file; fill this out 
if you’d like.  Click Close once you have finished adding your files. 
 

 
 
 

Checking Out a File 

 
To check out a file, in VSS navigate to the project/folder in the left-hand pane where your 
desired file is, right-click on the file in the right-hand pane.  Click on the Check Out popup menu 
item,  
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fill in any comment in the dialog box that appears (shown above), and click OK.  VSS may tell 
you that a folder is not found, and ask you if you want it created, as shown in the popup box 
below.  Click Yes or Yes All if you want the folder created.  We suggest you click Yes or Yes All 
since the directory structure on your hard-drive will mimic the VSS project structure. 
 

 
 

 
Your file is now located in a subdirectory under your Working Folder.  This subdirectory will 
mimic the project in the left-hand pane in VSS.  That is, if your file is located in the project 
$/SD/Test SAS Programs, and you have checked out a file called bob.sas, then the bob.sas file 
will be located in C:\TEMP\VSS\SD/Test SAS Programs.  Recall that you set your working folder 
to C:\TEMP\VSS, so anything you check out of VSS will be placed under this directory.   Once 
you check out a file, notice that the column labeled User is filled in, the Check Out Folder 
column is populated, and the icon on the left has changed as well.  
 
What Now? 

 
Now that your file is checked out, you can access and modify it off your hard-drive using your 
favorite editor or software application.  Be aware, though, that deleting this file on your hard-
drive does NOT automatically delete it from VSS!  At this point, you are back to predictability 
again since you open up the file and edit it the way you normally would without VSS. 
 
Checking In a File 

 
To store your modified file in VSS – and take advantage of its automatic versioning – you must 
Check In your file.  Locate the checked out file in the right-hand pane in VSS – look for the icon 
surrounded by a red square and has a red check mark – right click over the file name, and 
choose Check In....  The following dialog box pops up: 
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Fill out the comment in the dialog box you are presented with, check Remove local copy if you 

want to have it removed from your hard drive.  Don’t panic when you select this option, you are 
only deleting the version in your working folder on your hard-drive and NOT deleting it from 
VSS. Check Keep checked out if you want to have VSS store a new version, but you are still 

working on the file.  Click OK.   
 
At this point, VSS checks in the file and removes the red icon from the left of the file name.   
 
Make sure to Check In your files if there is a possibility a co-worker may want to use that file 
later on. 
 
Checked Out By Mistake 
 
If you accidentally checked out the wrong file, or checked out and erroneously modified a file, 
you can undo your check out by right-clicking on the file and choosing Undo Check Out.  This 

will remove the file from your hard-drive, remove the red check mark on the file icon, but NOT 
update the version in VSS with the erroneous changes you made. 
 
Deleting a File from Visual SourceSafe 
 
If you have added or checked in a file that later on you decide is not worthy of being in VSS, you 
can delete it by selecting the file name in the right-hand pane, right-click on it and select Delete. 
You will be presented with the following popup box: 
 

 
 

Click OK if you want the file deleted.  If you check Destroy permanently, VSS will delete the file 
and any versions of it in VSS.  Prudence with this option is advised. 
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Displaying Version History for a File 

 
Since VSS stores all versions of a file, you may want to see a report showing this.  Right-click 
over a file in the right-hand pane and click Show History….  The following dialog box will be 
displayed: 
 

 
 
At this point, you can just click OK and the report dialog box will pop up.  You can also fill in a 
starting date and ending date in the From: and To: input boxes in MM/DD/YYYY format.  Here is 
an example history report: 
 

 
 
You can click on the Details button to show the comments you made when you checked in your 
file…you did make comments, right!    You can use the Get button to get (but not Check Out) 
a version of your file on your hard-drive.  You can use the Diff button to compare and view two 
file versions in the history list, one file version in the history list against a file on your hard-drive, 
or two files on your hard-drive.  The output is a side-by-side view and makes it very easy to see 
where differences are.  To compare two file versions in the history list, select two versions and 
click Diff.  The following dialog box pops up: 
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Click on OK and you will be presented with a side-by-side view of the differences between the 
two versions.  To compare two files on your hard-drive, click on the Diff button and click the 
Browse button for the Compare: and the To: input boxes, select Windows folders, as shown 
above, and select your files.  Click OK.  Again, you will be presented with a side-by-side view of 
the differences between the two files. 
 
Note that you can start the Diff options by selecting Tools…Show Differences on the menu bar. 
  

Final Comments 
 
That’s the end of our brief introduction to Microsoft SourceSafe.  Once you become used to 
VSS, you too will continually say, “Check it out!  Check it out!”  (Singing and dancing is 
optional.) 
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Support sheepsqueezers.com 
If you found this information helpful, please consider 
supporting sheepsqueezers.com.  There are 
several ways to support our site: 
 

 Buy me a cup of coffee by clicking on the 

following link and donate to my PayPal 

account: Buy Me A Cup Of Coffee?. 

 Visit my Amazon.com Wish list at the 

following link and purchase an item: 

http://amzn.com/w/3OBK1K4EIWIR6 

Please let me know if this document was useful by 
e-mailing me at comments@sheepsqueezers.com. 

http://www.sheepsqueezers.com/
http://www.sheepsqueezers.com/
http://www.sheepsqueezers.com/joomla/index.php?option=com_content&view=article&id=92&Itemid=71
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